Table of Contents

guest
2019-12-08
Documentation
   Release Notes
   Create a folder in Panorama
   Folder navigation in Panorama
   Import data into Panorama
   Upload Raw Data
   Adding users to a project
   Submit Data to Panorama Public
   Download Data From Panorama Public
   Quality control with AutoQC
   Install Panorama

Documentation





Release Notes


Version 19.3, released November 2019

Panorama

  • Panorama Premium: Auto-enabling Metrics - Metrics are shown when relevant data is detected; these metrics are hidden when relevant data is not detected. (docs)
  • Skyline List Support - Lists defined in Skyline are imported and available in Panorama folders. (docs)
  • Isotopologue Metrics - Plot isotopologue metrics including LOD and LOQ when data is available from Skyline. (docs)
  • Total Ion Chromatogram Metric - In QC folders, track the total ion chromatogram area as a metric, scoped to the entire run. (docs)
  • Skyline Audit Log - Import the Skyline audit log into Panorama. (docs)

Version 19.2, released July 2019

Panorama

  • Zip files during upload - .raw and .d directories or raw data files (from Agilent, Waters, and Bruker instruments) are automatically zipped before upload to a Panorama files repository. (docs)
  • Premium Features for Panorama Partners: New features available exclusively to members of the Panorama Partners Program and on PanoramaWeb.org:
    • Panorama Premium: Outlier Notifications - Subscribe to email notifications for new QC folder data imports, or only when the number of outliers in a series of imports is over a threshold. (docs)
    • Panorama Premium: Configure QC Metrics - Configure which QC metrics are used for analysis. (docs)

Operations

  • MS1 Module Removed - The MS1 module has reached end of life and due to lack of usage, has been removed.
  • Internet Explorer - End of Support - LabKey no longer supports Internet Explorer. For details, see supported browsers.
  • Upgrade to Java 12 - Oracle has ended public support for Java 11, and as a result, LabKey has completely removed support for Java 11 in the 19.2.0 release. For details, see supported Java versions.
  • Upgrade Tomcat Version - If you are using Tomcat 7 or 8, be sure to update to the latest point release. LabKey Server version 19.2.0 will be incompatible with Tomcat releases prior to 7.0.76 or 8.5.12. If you are using an incompatible version, you may see JSP compilation errors. Tomcat 9 releases (beginning with 9.0.0) are compatible and will not see these errors. For details, see supported Tomcat versions.

Development

  • Source Code Migration to GitHub - Core LabKey Server modules have been migrated from SVN to GitHub, as well as the central automated test code and all of the modules from server/customModules. (docs | docs)
  • Performance improvements by caching virtual schema metadata - Database schema metadata has always been cached, but beginning with release 19.2.x, table and column metadata for user schemas (i.e., virtual schemas) is also cached per request. This improves performance when processing complex queries.

Version 19.1, released March 2019

Panorama

  • Improved Replicate Views - The replicate view of a Skyline document now highlights the annotations present in that single file, as well as showing more information about the samples being used.
  • QC Folder Optimizations - Page load times for QC folders with substantial amounts of data should be improved.
  • Import Optimizations - The time required to import a Skyline document has been reduced, by 50% or more in many cases.

Security

  • See User and Group Details Role - Allow non-administrators to see email addresses and contact information of other users as well as information about security groups. (docs)
  • Enforce CSRF Checking - All POST requests must include a CSRF token. This is no longer a configurable option. (docs)

Sample Management

  • Sample Set Updates - The sample set creation and import pages have been streamlined and standardized. Performance has been improved when importing large sample sets, as well as for query and update operations. (docs).

Administration

  • Configure Allowable External Redirects - Create a whitelist of allowable redirects to external sites. (docs)

Operations

  • Upgrade to Java 12 - We strongly recommend upgrading your server installations to Oracle OpenJDK 12 as soon as possible. 19.1.x installations will continue to run on Java 11, but site administrators will see a warning banner. Oracle has ended public support for Java 11; as a result, LabKey will completely remove support for Java 11 in the 19.2.0 release. For details see Supported Technologies.
  • Remove Support for Java 8 - Oracle ended public support for Java 8 in January 2019; as a result, LabKey Server no longer supports Java 8. For details, see Supported Technologies.

Potential Backwards Compatibility Issues

  • Remote API Date Format Change - The date format in JSON responses has been changed to include milliseconds: "yyyy-MM-dd HH:mm:ss.SSS". In previous releases the following format was used: "yyyy/MM/dd HH:mm:ss".
  • Removal of Legacy JFree Chart Views - Existing charts of these older types are rendered as JavaScript charts. No action is needed to migrate them. (docs)
  • Legacy MS2 Views - Options in the Grouping and Comparison views previously marked as "legacy" have been removed.
  • User and Group Details Access Change - Access to contact information fields in the core.Users and core.SiteUsers queries, the core.Groups query, and the getGroupPerms API now require the Administrator or "See User and Group Details" role.
  • External Redirects Change - External redirects are now restricted to the host names configured using the new Configure Allowable External Redirects administration feature. The 18.3.x experimental feature that unconditionally allowed external redirects has been removed.
  • POST Method Required for Many APIs - Many LabKey APIs and actions have been migrated to require the POST method, which has security benefits over GET. The LabKey client APIs have been adjusted to call these server APIs using POST, but code that invokes LabKey actions directly using HTTP may need to switch to POST.

Upcoming Changes

  • End of Support for IE 11 - Support for IE 11 will end in the upcoming LabKey Server 19.2.0 release, scheduled for July 2019. Please contact us for workaround options if this change strongly impacts you. (docs)

Version 18.3, released November 2018

Panorama

  • Normalized Y-axes in QC Plots - Support for normalizing Levey-Jennings and Moving Range plots using percent of mean or standard deviation as the zero point on the Y-axis. (docs)
  • Improved Figures of Merit performance - Rendering performance for the Figures of Merit report has been improved. (docs)
  • Read Chromatograms Directly from SKYD files - An experimental feature allows you to read chromatograms directly from SKYD files instead of storing them in the database. (docs)

Administration

  • Subfolder Web Part - This web part shows the subfolders of the current location; included in new collaboration folders by default. Also available in the 18.2 release. (docs)
  • Connect to Existing Amazon S3 Directories - Connect to an existing S3 directory or create a new one for each LabKey folder. (docs)
  • Improved Navigation Menu - The project menu and any custom menus you define have a more consistent interface, and each contain graphical elements signaling that they are interactive elements. You can also access the project menu from the admin console. (docs)

Reporting and Visualization

  • Scatter and Line Plot Enhancements - Specify multiple Y axes. Show all data on a single plot or display separate plots per measure. (docs | docs)

Development and APIs

  • NaN and Infinity Values - LabKey SQL supports constants NaN, INF, and -INF. (docs)

Potential Backwards Compatibility Issues

  • Changes to CSRF Setting - At 18.3 upgrade time, the CSRF checking setting on all servers will be set to "All POST requests". Site administrators will have the ability to revert back to "Admin requests" for deployments that still need to make their external modules or custom pages compatible with this setting. For release 19.1, we plan to remove the setting entirely and check CSRF tokens on every POST (except for specially annotated actions). When servers are protecting against CSRF attacks, they will require the following minimum versions: Skyline - 4.2; Skyline-daily - 4.1.1.18151; AutoQC Loader - 1.1.0.18302 (docs)

Operations

  • Support for Java 11 - We recommend upgrading your server installation to Java 11. Oracle is expected to end public support for Java 8 in January 2019, and, as a result, LabKey Server will no longer support Java 8 for the 19.1 release. For details see Supported Technologies.
  • Support for PostgreSQL 11 - PostgreSQL 11.1 and above is supported (not the initial PostgreSQL 11.0 release). For details, see Supported Technologies.
  • Remove support for PostgreSQL 9.3 - PostgreSQL 9.3 reached end-of-life in November 2018. We recommend upgrading your PostgreSQL installation to version 10 or later. For details, see Supported Technologies.
View the full LabKey Server 18.3 release notes.

Version 18.2, released July 2018

Panorama

  • Improved Pharmacokinetic Report - Pharmacokinetic (PK) calculations are provided per subgroup, replicate annotations are included, and non-IV routes of administration are supported. (docs)
  • LOD/LOQ Skyline Compatibility - Limit of Detection (LOD) is now shown in Panorama, and there is support for additional Limit of Quantitation (LOQ) configuration as defined in Skyline. (docs)

System Integration

  • Spotfire Integration - Use data stored in LabKey Server to create Spotfire visualizations. (docs)

LabKey SQL

  • Common Table Expressions - Use a SQL "WITH" clause to simplify complex queries and create recursive queries. (docs)

Development

Potential Backward Compatibility Issues

  • Changes to CSRF Default Setting In 18.2, we have switched the default CSRF checking setting (affecting only new servers) to "All POST requests". We recommend that all clients run their servers with the "All POST requests" setting, ideally on production servers but at a minimum on their tests/staging servers. In the upcoming 18.3 release, we plan to force the setting (on all existing servers at upgrade time) to "All POST requests". We will retain the ability to revert back to "Admin requests" for deployments that still need to make their external modules or custom pages compatible with this setting. For release 19.1, we plan to remove the setting entirely and check CSRF tokens on every POST (except for specially annotated actions).

Operations

  • Tomcat 8.0.x is no longer supported - If you are using Tomcat 8.0.x, you should upgrade to 8.5.x at your earliest convenience. No configuration changes in LabKey Server are necessary as part of this upgrade. For details see Supported Technologies.
  • Connection Pool Size - We recommend reviewing the connection pool size settings on your production servers. For details, see Troubleshooting.
View the full LabKey Server 18.2 release notes.

Version 18.1, released March 2018

Panorama

  • Pharmacokinetic Calculations - See the stability, longevity, and uptake of compounds of interest. (docs)
  • Figures of Merit for Quantitation Data - Summary statistics show the mean, standard deviation, and %CV for the replicates, along with lower limit of detection, quantitation, etc. (docs)

Collaboration

  • Files Table - All files under @files, @pipeline, and @filesets in a container can be managed using a new exp.Files table. Developers can use exp.Files to programmatically control all files at once. (docs)
  • Messages Default to Markdown - Markdown is a simple markup language for formatting pages from plain text, similar to LabKey's Wiki syntax. The Messages editor window includes a Markdown syntax key and message preview tab. (docs)

Security

  • New Role: See Absolute File Paths - A new site-level role allows users to see absolute file paths in the File Repository. (docs)
  • Impersonation Auditing - Audit records are created when a user starts or stops impersonating a role or group. docs)
  • API Keys - Client code can access the server using API keys. Administrators can allow users to obtain new API keys and manage when keys expire. (docs)
  • Captcha for Self Sign-up - Self-registration now includes a captcha step to prevent abuse by bots. (docs)
  • Cross-Site Request Forgery (CSRF) Protection Changes - All LabKey pages have been tested and updated to protect against CSRF. We recommend that site admins change the default CSRF protection setting to "All POST requests" to enable this increased protection. This may cause issues with custom pages that are not configured to submit CSRF tokens when doing an HTTP POST. For details see the Potential Backwards Compatibility Issues section below.

Operations

Potential Backwards Compatibility Issues

  • New Cross-Site Request Forgery Protection (CSRF) Recommendation - We recommend that administrators begin the process of converting their servers from the current default CSRF protection setting of "Admin requests" to "All POST requests". The more stringent security setting may cause issues for custom pages that submit HTTP POST requests. If you have no custom pages or forms, we recommend that you immediately change the CSRF setting for all test, staging, and production servers running 18.1. If you have custom pages and forms, we recommend that you begin testing on your test and staging servers. In a future release, LabKey Server will enforce that all HTTP POSTs include the CSRF token, at which point all custom pages will be required to be do so. For details on configuring custom pages with CSRF protection, see here.
View the full LabKey Server 18.1 release notes.



Create a folder in Panorama


To get your data into Panorama, first create a folder.

  • Hover over your project name in the menu bar below the Panorama icon and click on the New Subfolder icon shown in the image below. 

  • Select the Panorama option under Folder Type.  This is the folder type that should be selected for all workflows supported by Skyline (SRM-MS, MS1 filtering or MS2 based projects).  

 

  • On the Users / Permissions page select one of the available options and click Next.  You can also change permissions on a folder after it has been created.
  • The next page (Configure Panorama Folder) asks you to choose the type of Targeted MS folder you would like to create.  Panorama offers threechoices here.  
    • Choose the Experimental data option for folders that serve as a repository of Skyline documents, useful for collaborating, sharing and searching across multiple experiments. 
    • Choose Chromatogram library to store curated assays that can be used for designing and validating future experiments.  Check Rank peptides within proteins by peak area if your data contains relative peptide expression for proteins. 
    • Choose the QC option for tracking performance of mass spec. instruments over time. 

  • Click the Finish button. 

See the LabKey documentation for more information on creating and managing folders.




Folder navigation in Panorama


To navigate to your available projects and subfolders, hover over the folder icon or the current project name, located at the top left corner, just under the Panorama logo. 

Project navigation: Hovering over the folder icon to the left displays all the projects that you have access to on PanoramaWeb. Clicking on the project name (e.g. “MacCoss”) will take you to the home page of the project.

Folder navigation: The menu provides a tree view with expandible/collapsable nodes for navigation to sub-folders. Clicking on a folder name navigates to the home page of the folder.

Also see: LabKey Documentation: Navigate Server




Import data into Panorama


You can import data into a Panorama server either directly from Skyline or from Panorama's web-browser interface.

Importing data into a Panorama server from Skyline

Open the document that you want to publish to Panorama.

  • Click on the Upload to Panorama button in the toolbar, as shown below.  Alternatively, on the File menu, click Upload to Panorama.

  

  •  If you have not already registered a Panorama server in Skyline you will see the following message.

If you have an existing account on a Panorama server, and you would like to use that, click on Continue and enter the server details in the Edit Server form Skyline presents.  If you do not have an existing Panorama account, you can request a project on the PanoramaWeb server hosted at the University of Washington by clicking on Register.


In the Edit Server form enter the server URL and the email address and password for your account on the server. Click OK. Skyline will now display a form with the folder hierarchy on the Panorama server.

  • Select a folder on the server where you want to add the document.
  • Click the OK button. 

Skyline will create a ZIP archive of the files for your document and upload the ZIP file to the Panorama server, where it will be imported into the Panorama database. 

 




 

Importing data into a Panorama server via a web-browser

Using the Skyline Upload to Panorama toolbar button or menu item is the most convenient way to get your documents into Panorama.  But this can also be done by using the Panorama web interface.

  • In Skyline, open the file you want to import into Panorama.
  • In the File menu click Share.

  • Save the ZIP file on your computer using the Share Document form presented by Skyline.
  • In Panorama, navigate to your folder.
  • Click the Data Pipeline tab in the upper right corner.
  • Click on Process and Import Data as shown below.

  • In the Files browser, click Upload Files
  • Click the Browse button and select the file that you want to import.
  • Click the Upload button.

Once the file has been uploaded it will appear in the list of files in your folder

  • Check the box next to your file name.
  • Click Import Data in the toolbar, beside the Upload Files button

.

Wait for the file import to complete and then click the Panorama Dashboard tab in the upper right corner.  Your file should be listed under Targeted MS Runs. You can click on the file name to view the results. 

 






Upload Raw Data




Upload raw data in a web-browser

Raw data associated with Skyline documents in a folder can be uploaded via the Raw Data tab in the top right corner.
(NOTE: If you don't see a Raw Data tab click here for instructions on how to add it)



Click the tab to see a Files browser. You can drag-and-drop files and/or folders located on your computer onto the Files browser as shown in the image below.



Another way to upload files is to click the Upload Files button in the Files browser, and click Browse to navigate to and select the file you want to upload.



Organizing data in folders

Raw data files can be organized in folders. Create a new folder by clicking the new folder button in the Files webpart.


Enter a name for the folder and click Submit.


Click the Show or Hide Folder Tree button to show the folder tree panel.


Click the newly created folder in the folder tree panel to select it. The right panel will update to show the contents of the selected folder. Drag-and-drop files in the right panel to upload them to the new folder.



More information on using the Files browser can be found here: Using the Files Repository


Upload raw data by mapping a network drive in Windows

On a Windows machine you can map your PanoramaWeb folder as a network drive and copy files to the folder using Windows Explorer. This uses WebDAV for file transfer, and Windows XP and later have a built-in WebDAV client.

NOTE: The instructions below will work on Windows 10 and Windows Server 2016. If you have an older operating system and are unable to map a network drive with these steps then you can use a third party WebDAV client such as Cyberduck. Look at this page for instructions on setting up Cyberduck and for a list of other WebDAV clients: Example Setup for Cyberduck WebDAV Client

To map a PanoramaWeb raw data folder as a Windows network drive follow these steps:
  • In a web-browser navigate to the Panorama folder and click the Raw Data tab
  • Click the Upload Files button in the Files webpart (1. in the screenshot below)
  • Click the "Upload file" icon (2. in the screenshot below).
  • From the File Upload Help dialog copy the WebDav URL (3. in the screenshot below)

  • On your computer open Windows Explorer. Right-click This PC in the left pane and select Map network drive from the menu


  • In the Map network drive dialog enter the WebDav URL that you copied from your Panorama folder. Check Connect using different credentials and click Finish
  • You will be prompted for a username and password. Enter your PanoramaWeb email address and password and click OK
This should map the PanoramaWeb folder as a network drive on your computer, and you should be able to copy files to the folder just as you would to a another folder in Windows Explorer. Once you are done copying files you can disconnect the network drive by right-clicking the mapped drive and selecting Disconnect network drive from the menu.


Adding the Raw Data tab

The Raw Data tab is added by default when you create a new "Panorama" type folder. Some older folders may not have this tab. If you do not see the Raw Data in a "Panorama" type folder, and you are the administrator of the folder, you can add it as follows:
  • Click the gear icon in the top right corner
  • Select Add Raw Data Tab from the drop-down menu



Adding users to a project


If you are the administrator of a project on panoramaweb.org, you can follow these steps to add users from your lab or organization to the project.

 

  • Click on the Gear Icon  , as shown in the image below.
  • Click Folder and then click  Permissions.

  • On the permissions page click on the Project Groups tab.
  • Click on the "Users" group.  This is a group that is created for every project on Panorama.

  • In the Users Information popup click on Manage Group.

  • Enter the email addresses of new users in the Add New Members text box. 
  • Click on Update Group Membership.

  • Any users that did not already have accounts on the Panorama server will be added to the system, and a welcoming email will be sent to them.
  • Click on Permissions in the navigation trail, as shown in the image below, to go back to the permissions page.

  • Assign the Users group to the Reader role, as shown in the image below.  All users that are members of the Users group will have read access to the project.

 

To make a folder public assign Site:Guests to the Reader role. Anyone with a link to the folder will be able to view it without having to log in.

For more information on the adding / managing users and security roles look at the LabKey documentation on LabKey security architecture.




Submit Data to Panorama Public


PanoramaWeb hosts a public repository called Panorama Public where users may submit supplementary data associated with manuscripts that have been published or are under review. The repository provides a permanent location for data that can be referenced in publications. Users with data in their own projects on PanoramaWeb can follow the instructions below to submit the data to Panorama Public. The PanoramaWeb site administrators will review the submission request and make a copy of the data to Panorama Public. Reviewer account details will be provided to the submitter if the data is for a manuscript undergoing peer review, and the copy on Panorama Public will be kept private until the manuscript is accepted for publication. Data copied to Panorama Public is read-only, ensuring its availability in the original form accepted for publication.

New: Panorama Public is a now a member repository of the ProteomeXchange consortium. Data submitted to Panorama Public that fulfills ProteomeXchange submission requirements will be assigned a ProteomeXchange ID and announced on ProteomeCentral.

Submitting Data to Panorama Public

STEP 1: Upload Skyline documents to a folder on PanoramaWeb

Refer to the following wiki pages to create a folder in your project on PanoramaWeb and upload Skyline documents and associated data.


STEP 2: Prepare the folder for submission to Panorama Public

Folders containing supplementary data intended for submission to Panorama Public have to be annotated with a description of the experiment. This includes information such as an abstract, experiment and sample descriptions, organism, MS instruments used etc. To add experiment annotations to a folder, do the following:

  • Go to the home page of the folder by navigating the folder menu under the Panorama logo (Folder Navigation).
  • Click the gear icon in the top right corner of the page, then select Page Admin Mode from the drop-down menu.
  • Scroll to the bottom of the page and select Targeted MS Experiment from the <Select Web Part> menu at the bottom-left of the page.
  • Click the Add button. This action will add a web part titled Targeted MS Experiment at the bottom of the page that looks like this:
  • Click the Create New Experiment link in the Targeted MS Experiment web part.
  • Fill out the Targeted MS Experiment form.

The Instrument and Organism fields are auto-complete fields. Type 3 or more letters to see a drop-down list of matching options. Continue typing to refine the list and select from one of the available options. Contact the Panorama team if you do not see your instrument or organism in the list. At least one organism and one instrument is required for a ProteomeXchange submission.

In addition to an organism and an instrument, Keywords describing the data also need to be filled in for a ProteomeXchange submission. Contact details of the data submitter and a lab head are also required. In the Targeted MS Experiment form, the currently logged in user is auto-selected as the submitter. Please fill in the Submitter Affiliation for the submitting user. You can select a lab head from the drop-down menu in the Lab Head field which lists all users that have administrative privileges in the folder. If your lab head does not have an account on the server, you may create one by referring to Adding Users to a Project. If you do not wish to create an account for the lab head you can leave the Lab Head and Lab Head Affiliation fields blank. You will have the option of entering a lab head name and affiliation when you submit the data to Panorama Public.

  • Click the Submit button at the bottom of the form.
You will be taken to the experiment details page. All the Skyline documents that were uploaded to the folder where you added the Targeted MS Experiment webpart will get added to the experiment and will appear in the Targeted MS Runs table. If your data is organized in subfolders under the main folder, you should click the Include Subfolders button shown in the image below.


STEP 3: Submit the annotated folder to Panorama Public
  • Navigate back to the folder home page by clicking on the link with the icon and folder name near the top of the page.
  • Scroll down, if you need to, so that you can see the Targeted MS Experiment web part.
  • Click the red Submit button in the Targeted MS Experiment web part.


Your data will be checked for completeness for a ProteomeXchange submission. If there is missing information, such as missing raw data or missing metadata, it will be listed on a page after you click the Submit button. You can click the submit button again after you have provided all the missing information. Alternatively, if you do not want a ProteomeXchange ID for your submission you can proceed to the submission form by clicking the Continue without ProteomeXchange ID link shown below.


After you have provided all the missing information or clicked on the link to continue without a ProteomeXchange ID you will be presented with a form that looks similar to the one in the image below:


If you did not enter a lab head in the Targeted MS Experiment form, and a ProteomeXchange ID will be requested for your data, you will see additional fields in the form:

If you do not fill in the lab head details in this form, the submitting user's information will be used in the lab head field when announcing the data to ProteomeXchange.

In the Submission Request to Panorama Public form do the following:
  • Select “Panorama Public” from the drop-down list next to the Publish To option, if it is not already selected
  • Enter an Access Link
  • If you are submitting data for a manuscript undergoing peer review leave the Keep Private box checked. This will ensure that when the data is copied to Panorama Public, it will be kept private with read-only access to the submitter. Another read-only reviewer account will be created for the data, and account details provided to the submitter. The account details can be conveyed to the journal where the manuscript is submitted. If, however, you want your data to be publicly available on Panorama Public right away uncheck the Keep Private checkbox.
  • Click the Submit button
Access Link is the link that you will include in your manuscript to link to supplementary data on Panorama Public that can be viewed in a web browser. Initially, this link points to your folder on PanoramaWeb. But once a copy of your data has been made to Panorama Public, it will link to the location of the copied data on Panorama Public. This will be the permanent location of your supplementary data on Panorama Public.

The Publish Experiment form allows you to “build” these the access link. The initial part of the link remains constant: https://panoramaweb.org/. You can choose a string to complete the link (highlighted in yellow below).
https://panoramaweb.org/choose_a_string.url
The initial value entered in the Access Link field is a randomly generated alphanumeric string. You can replace it with a convenient, easy to remember string. This string has to be unique across all the experiments published to Panorama Public. You may get an error if the link you entered is already in use for another experiment on Panorama Public. If this happens change the text in the access link field and try again.

Requests to copy data are handled by Panorama Public administrators within a week of submission. Once your data has been successfully copied to Panorama Public you will receive a confirmation email. If you requested that your data on Panorama Public be kept private (e.g. for a manuscript under peer review), the confirmation email will also include reviewer account details. You can pass on the account details to the journal where you are submitting your manuscript. The confirmation email will also include a ProteomeXchange ID unless you opted to skip ProteomeXchange submission.

Once the form is submitted successfully you can go back to the experiment details page.

In the Experiment Details box, just above the experiment title, you will see a “Copy Pending!” message. This message will disappear once your data has been copied to Panorama Public. Any changes that you make in the folder, such as adding/removing Skyline documents or wiki pages, or changing the layout of the page will also get copied when a copy is made to Panorama Public. At the bottom of the page, in the Submission table, you will see the Access Link that you created for this experiment. The Copied column will be blank until a copy has been made successfully. Once the data has been copied this column will display the date when the data was copied. And at that point if you click the Access Link you will be taken to the location on Panorama Public where your data was copied. You can verify that the data, folder layout and views were copied accurately.


If you need to make any changes to your data (e.g. to address reviewer feedback) after it has been copied to Panorama Public you can make the changes in your own folder. When you are ready click the red Resubmit button in the Targeted MS Experiment web part. This will send a request to the Panorama Public administrators to delete the old copy and make a new copy of your data to Panorama Public. Your access link will remain unchanged.


Related Resources:



Download Data From Panorama Public



Download Skyline documents

Skyline documents available in a public dataset can be downloaded by clicking the download icon ( ) next to the document name. In the pop-up menu click Full Skyline Document. This will download a .sky.zip file which can be opened in Skyline.


Download raw data in a web-browser

Raw data uploaded with a dataset is available under the Raw Data tab in the top right corner. Click the tab to view a list of files available for downloading. Select one or more files and click the download icon ( ).


To select all the files listed in the files browser, select the first file in the list by clicking the name of the file in the File column. Press the Shift key and then select the last file by clicking the file name. This will select all the files between the first and the last selected files. Please note that this will not work if you use the checkboxes next to the file names to select files. Click files names instead to select files.

Download raw data using WebDAV

Files can also be downloaded using the WebDAV protocol. On Windows the raw data folder can be mapped as a network drive in Windows Explorer. Other WebDAV clients such as CyberDuck or WinSCP can also be used to connect to the folder.
In the Download Data panel below the files browser in the Raw Data tab you will find the WebDAV URL (example screenshot below) along with the email address and password that is needed to connect to the folder.



Map folder as a network drive in Windows

  • Copy the WebDAV URL displayed in the Download Data panel under the files browser in the Raw Data tab.
  • On your computer open Windows Explorer. Right-click This PC in the left pane and select Map network drive from the menu.


  • In the Map network drive dialog enter the WebDav URL copied in step 1. Check Connect using different credentials and click Finish.
  • When prompted for a username and password enter the email address and password from the DataPanel in the Raw Data tab and click OK.

This should map the folder as a network drive on your computer, and you should be able to copy down the desired files to another folder in Windows Explorer. Once you are done copying files you can disconnect the network drive by right-clicking the mapped drive and selecting Disconnect network drive from the menu. Please note that this works in Windows 10 and Windows Server 2016. If you have an older operating system and are unable to map a network drive with these steps then you can use a third party WebDAV clients such as CyberDuck and WinSCP.

CyberDuck (https://cyberduck.io/)

  • Click Open Connection.

  • In the Open Connection dialog select WebDAV (HTTPS) as the connection type.
  • In the Server field enter the WebDAV URL copied from the Download Data panel in the Raw Data tab. CyberDuck will automatically parse the URL and populate the Path field.
  • In the Username field enter public@proteinms.net.
  • In the Password field enter panorama.
  • Click Connect.



WinSCP (https://winscp.net/eng/index.php)

  • In the Login dialog select WwbDAV under File Protocol.
  • Copy the WebDAV URL in the Host name field. WinSCP will automatically parse the remote directory path from the URL, and you will only see "panoramaweb.org" in the field.
  • Enter public@proteinms.net under User name.
  • Enter panorama under Password.
  • Click Login.




For options on OSX and Linux see this link: Native OSX and Linux WebDAV Clients




Quality control with AutoQC


Skyline and Panorama combine to provide a robust QC workflow for LCMS instrumentation used in proteomics experiments. AutoQC Loader, a utility application, uses SkylineRunner to invoke Skyline without user interface for automated data processing. AutoQC Loader can be run on an instrument control computer to capture new QC runs automatically, and add them to an existing Skyline document, where the information is archived for later use and transferred to Panorama. Panorama retains a full history of QC run performance, and presents users with interactive plots for key metrics including retention time and peak area. Additionally, users can add information about changes including instrumentation, maintenance, and reagents, which are overlaid on the plots, providing a convenient way to correlate cause and effect.

[Install] AutoQC Loader for Skyline 3.5 or later
Note:You can download and install AutoQC Loader unplugged on computers with issues connecting directly to the internet.

[Install] AutoQC Loader-daily for Skyline-daily (3.1.1.8694 or later)
Note:You can download and install AutoQC Loader-daily unplugged on computers with issues connecting directly to the internet





Install Panorama


Panorama has been implemented as a module within LabKey Server, and is included in the official release of LabKey Server as of v12.3.  You can download the latest release of LabKey Server here for a new installation or to upgrade an existing one.  See LabKey installation documentation for available install options.

Once you have a running LabKey Server you can set up a workspace for your lab or group by creating projects and folder, and configuring user and group permissions for authenticated access to the workspace.  Please see the LabKey documentation for:

For additional documentation and help regarding Labkey Server please visit the LabKey support page.

For information on creating folders in Panorama, see Create a folder in Panorma

For more information on getting your data into a Panorama server see Import data into Panorama.