View Message
Upload error phains  2017-07-18
 
Hi,

I am having similar issues to those already described. First off, I'm using LabKey 17.2 (just upgraded, but the issues were occurring with the prior version), AutoQC is V 1.1.0.10626 and Skyline is V3.7.0.10940, all 64-bit, Win 10 for AutoQC and Skyline or Win server 2012 for LabKey.

All my current AutoQC methods are working fine. These were made sometime ago with an earlier version of Skyline. The problem occurs when I try to make a NEW AutoQC config. I opened up one of my working methods, saved the Skyline file using the latest version of Skyline and now it does not work.

The symptoms: When I start the config in AutoQC it does not make an AutoQC.log file. If I make one manually this part then works fine. The file are imported in to Skyline but the Panorama upload fails.

The AutoQC log and Panorama log are attached.

By the way, we still have the issue with AutoQC giving up the ghost every few days when monitoring network drives. It’s annoying, but we just stop the config and start it again...

Thanks,

Peter
 
 
vsharma responded:  2017-07-19
Hi Peter,

AutoQC 1.1.0.10626 has a bug in that it does not create the AutoQC.log file, as you have discovered! So sorry about that. I will be releasing an update by next Monday that will fix the bug. It will also have better handling of network mapped drives.

I have not seen the Panorama error before. Is it possible for you to share your Skyline document with me (File > Share in Skyline)? If it is too big to be added as an attachment either to this message or via email (vsharma@uw.edu), I could give you access to our FTP server.

Thanks,
Vagisha
 
phains responded:  2017-07-19
Hi Vagisha,

I'll meet you in the middle, a Dropbox link to the Skyline file is below. Thanks for your assistance,

Peter


https://www.dropbox.com/s/rtbrsryzb1zsoyj/PGH_RMIS_RTK_QC_PC1.sky.zip?dl=0
 
vsharma responded:  2017-07-20
Hi Peter,

Thanks for sharing the file. Unfortunately, uploads from Skyline v3.7 to LabKey Server v17.2 are broken right now. We have a fix that will be committed in a day or two. And LabKey should have a patch release soon after that. I will keep you updated. Sorry for all the trouble.

Thanks,
Vagisha
 
vsharma responded:  2017-07-24
Hi Peter,

A new release of LabKey Server is now available that fixes the Skyline 3.7 to Panorama upload bug. Please give it a try and let me know if you still have issues.

I have also updated AutoQC to 1.1.0.11134 (http://skyline.gs.washington.edu/software/AutoQC/index.html). This should handle network mapped drives better, and there should be more verbose output in the program log (AutoQCProgram.log in the directory where AutoQCLoader is installed). Please give it a try and let me know how it goes.

AutoQCLoader will self-upgrade when you restart it. But, before you upgrade please save your configurations. They get stored in a user.config file, usually in one of the subfolders in this location:
C:\Users\<username>\AppData\Local\Apps\2.0\Data\<...>\<...>\auto...tion_<hash>\. You could do a search for user.config files in C:\Users\<username>\AppData\Local\Apps\2.0\Data. You will likely find several. Look for the latest one that has these elements:
<ConfigList>
<autoqc_config ...></autoqc_config>
...
</ConfigList>

Save this file in a separate location. The upgrade process should preserve user.config. But in case something goes wrong, and you lose your configurations, you can import the older user.config by clicking on the new "Import" button in AutoQCLoader.

One thing I have noticed with this upgrade is that on one of my machines I had to re-enter my Panorama password in the "Panorama Settings" tab. Sorry if you have to do that too.

Thanks!
-Vagisha
 
phains responded:  2017-07-24
Hi Vagisha,

awesome…

It’s all working fine again. Thanks to all for the rapid response time.

FYI, I did have to enter the Panorama pwd. No big deal. And it did preserve the config during the update.

Regards,

Peter