Collision Energy per transition displayed as "0.0000".

support
Collision Energy per transition displayed as "0.0000". Roman Sakson  2021-07-20 13:37:43
 

Dear Panorama team,

I am now in the process of uploading a targeted MS Run to Panorama (preparation to publish). This is some MRM data where CEs were optimized for each transition. An optimized library ".optdb" as well as the usual CE Equation were selected in the transition settings in Skyline at the moment of data upload to the Panorama folder. When I click on the peptides in Panorama in the MS Run, one CE as well as one DP-value per peptide are being displayed, those values are probably derived from the equations. However, when I select transitions to be displayed and I customize the grid for CE values to be shown at transition level, I am getting a CE value of 0.0000 everywhere. I expected my optimized CE values to appear there, am I doing something wrong?

Thanks a lot in advance,
Roman

 
 
vsharma responded:  2021-07-20 17:26:18

Hi Roman,

This looks like a bug in the Panorama code that is reading transition data saved in 'compact' format in the Skyline file. We will fix the bug. In the mean time you can do this in Skyline as a workaround:

  1. Go to Tools > Options. Select the "Miscellaneous" tab
  2. Change the setting for "Use compact format when saving Skyline documents" to "Never".
  3. Upload the file to Panorama

Please remember to change the setting back to the default ("Only for large files") otherwise your .sky files will be much bigger!

Thanks for reporting the bug.

-Vagisha

 
Roman Sakson responded:  2021-07-21 10:21:49

Hi Vagisha,

thank you, this works for me now!

A more general question about what parts of my Skyline document actually get uploaded to Panorama: normally I do not have project-specific optdb and irtdb files but centralized large files to which I keep adding new peptides to. For instance, when I now have such a large optdb file selected under transition settings, will only CE values of transitions from the Skyline document be uploaded to Panorama or could someone somehow also see what other transitions are present in my whole optdb file?

Along that lines: Skyline now exports and stores the total TIC area, even when only few peptides are actually present in the Skyline document. This is very useful for QC, however I wonder whether other data from my raw files get uploaded to Panorama as well, which could potentially be used to extract new XIC traces? Or would one need the raw data for it?

Thank you,
Roman

 
vsharma responded:  2021-07-21 17:53:47

Hi Roman,

It turns out that the bug was not in the Panorama code. Skyline was not writing the transition collision energy values to the 'compact' format. The fix will be in the next Skyline-daily, hopefully.

The .sky.zip that Skyline uploads to Panorama (File > Upload to Panorama menu) is the same as what you would get if you created a shareable ZIP in Skyline using the File > Share menu. It contains the following files:

  • .sky file (Skyline XML document)
  • .skyd file (chromatogram data cache)
  • .sky.view (state of the Skyline UI when the document was last saved)
  • Any libraries that were used - .blib, .irtdb, .optdb etc.
  • Background proteome if one was used (.protdb)

You can see the complete list of files here: https://skyline.ms/announcements/home/support/thread.view?rowId=44111
When you create a shared ZIP in Skyline you have the option to "Store everything" or "Minimize libraries". The second option will remove entries form the library that do not match targets in the documents. It used to be that uploads to Panorama used the "Minimize libraries" option as the default. But I think that has changed, and the default now is "Store everything". So for your document the .optdb that gets uploaded with the .sky.zip to Panorama should contain everything. But I will check and get back to you.

On Panorama, we don't have a UI for viewing the full contents of an .optdb file included in a .sky.zip file. We only extract the information that is relevant to the targets in the document, so you will only see CE values for the transitions in your document. However, one can download the .sky.zip file, extract the contents and view the included .optdb file in a SQLite viewer such as SQLite Expert Personal.

Skyline extracts TIC, BPC and pressure traces from the raw data and stores them in the Skyline document. TIC and pressure traces are available in Panorama QC folders. Support for pressure traces is new in Panorama and will be available on PanoramaWeb when we deploy the new version in a week or so. You can read more about it here: https://www.labkey.org/Documentation/wiki-page.view?name=premPanoConfigMetrics#trace. You will not be able to extract new XIC traces, however.

Thanks,
Vagisha

 
Roman Sakson responded:  2021-07-22 12:57:43

Hi Vagisha,

thank you very much, this is very educational. It is also interesting to see an overview of Panorama Premium features, as our institute is at the moment considering pros and cons of getting a free, private Panorama server instead of PanoramaWeb. If I understand correctly, we would lose access to those features then?

I uploaded a shared ZIP to Panorama, then downloaded my ZIP again from another PC and I could access the full libraries via Skyline directly upon extraction, also for peptides not present in the document. This also works if uploading the compact version to Panorama in the first place. So, I guess to prevent that from happening I would need to remove all entries from my libraries that are not relevant for the document before the Panorama upload.

Kind regards,
Roman

 
vsharma responded:  2021-07-22 13:59:09

Hi Roman,

The premium Panorama features are available for free to PanoramaWeb users. If you were to setup your own server using the free community edition of LabKey Server you will not get these features. You can consider becoming a member of the Panorama Partner Program. This will give you access to the all the premium features along with LabKey support for server installation, maintenance, bug fixes etc. You also get to participate in regular Panorama Partners meetings with the LabKey and Skyline teams to discuss priorities for future development. You can learn more about this program here: https://www.labkey.com/products-services/panorama-partners-program/. Please let us know if you have any questions.

Thanks,
Vagisha