AutoQC loader disconnects from local servers

AutoQC loader disconnects from local servers David Kotol  2020-10-20 05:14:53

I have been struggling with the AutoQC for some time now. It works great but just for about 24 hours. Then I lose connection to local server where the data, in this case Thermo raw files, is stored. The connection to server remains lost until the PC is restarted.

To describe the problem:
1. QC sample is measured
2. Resulting file is automatically pushed to MassStorage local server (using
scheduler and .bat script) and to a designated folder
3. Another computer is running the AutoQC Loader and is paired
with the designated folder on the server
4. The QC software locates the result file on the server and uploads it
to the Panorama

This works for about 24 hours and then connection to the server is lost. The connection is restored by restarting the computer. But just for another 24 hours or so.

What I tried with always the same result:
- reinstall AutoQC Loader
- update AutoQC Loader
- use different computer
- reinstall and update Skyline

Is this a known issue or is it something with the servers of my institution, please? The institutional IT guys claim it is the software so I just want to check if anyone experienced this issue when loading raw files from servers and not the local storage.

All the best,
bconn responded:  2020-10-20 05:52:22

We have not had any other reports of a problem like the one your describing. Can you elaborate on the statement "I lose connection to local server where the data, in this case Thermo raw files, is stored"? Does the computer running the AutoQC Loader lose connectivity to the MassStorage local server?

If so, is the designated folder on the MassStorage local server is mounted on the computer running the AutoQC Loader using the Windows "Map a Network Drive" feature? When the connection is lost by the computer running AutoQC Loader, can you open Windows Explorer, on that computer, and access the mapped drive? If the mapped drive is disconnected, then I believe it must be a problem with the computer as the AutoQC Loader software does not have the ability to the disconnect a Mapped drive.

David Kotol responded:  2020-10-26 05:48:30

thanks a lot for your reply! I also feel it is not the software problem and I am glad you have never seen this issue before. Then I think our IT guys will have to look into it.

Yes, I use the Map a Network Drive feature. By saying I lose connection I mean that the files on the server can no longer be accessed. This applies for both AutoQC and Windows Explorer. The only fix I found to "work" is restarting the computer. After the restart, I can access the server with Explorer right away (no need to Map a Network Drive) and I can also re-initiate the AutoQC which then works for another day or so.