Import waiting indefinitely without anything happening

support
Import waiting indefinitely without anything happening dkueltz  2017-11-29
 
Hi Vagisha,
I noticed that lately it takes a very long time to upload a Skyline document to Panorama and sometimes I was not able to upload at all since the document is wait-listed infdefinetly (I have been waiting more than a day before cancelling and trying again). This is different from before when it took only a few minutes and I tried both importing directly from Skyline and via the web interface. Could you please take a look at the document that is currently "import waiting" listed and check what is wrong with it and why it does not start running?. It is in my JoLi-01 folder.
Thank you,
Dietmar
 
 
vsharma responded:  2017-11-29
Hi Dietmar,

It appears that all imports are stuck right now. I am taking a look to try to figure out the cause. There may be some issues with canceling a job, and then deleting it from the pipeline queue. I see in the logs that after you canceled the import for DIAVA_Gasac-Gill_MXLSAKBH4_min3.6_2017-11-28_09-51-59.sky.zip (late last night), and then deleted the job, none of the queued imports started.

Most likely I will be restarting the server to get the queue going again. I will keep you posted.

Thanks,
Vagisha
 
dkueltz responded:  2017-11-29
Thanks, Vagisha, for looking into this issue. I did cancel and restart import because it took too long (overnight) and the job never left the "Waiting to import" queue. Then I resubmitted the job that is currently queued. Sorry for causing this to halt all imports (although the cancelled job did not start either) but hopefully the reason that prevents restarting imports from the queue can be found and fixed.
Dietmar
 
vsharma responded:  2017-11-29
Hi Dietmar,

I re-started the server, and your document imported successfully this time. It took almost 40 minutes, however. This document is certainly much larger that the average size we see on PanoramaWeb. We will try to identify and fix any bottlenecks. I wasn't able to figure out why the import queue stalled, but I think it has to do with cancelling and deleting a job. I will try to reproduce the problem on a test server.

Thanks,
Vagisha