Error while uploading data to Panorama from Skyline-daily hana kucharikova  2020-11-06 06:58:32


I have encountered an error while uploading data from Skyline-daily ( to Panorama.
I am using GoogleChrome web-browser and Windows 10 OS (OS build 18363.1139).

I have opened my Skyline document, in section File press Upoload to Panorama, selected folder and start uploading the file. At the end of upload (when 98% was finished) an error message appear.

"Failed to complete task 'org.labkey.targetedms.pipeline.TargetedMSImportTask'
ERROR: SqlExecutor.execute(); uncategorized SQLException for SQL []; SQL state [25P02];"

There was also warning about Skyline versions incompatibility: "The version of this Skyline document is 20.14. This is newer than the highest supported version 4.1".

I have tried the upload again into new folder and after the notes in Skyline were removed, neither helped.

Detail information about the error log are in the attachment.

Can you, please, help me?
Thank you,

Vagisha Sharma responded:  2020-11-06 07:53:07

Hi Hana,

The error is: duplicate key value violates unique constraint "uix_auditlogentry_document"

This error happens if the document audit log contains two identical entries. We have seen this before and are still working to fix the bug. Here is a related support board request on the Skyline website:

The workaround is to remove audit log information from your document. You can do this by opening the audit log (View > Other Grids > Audit Log) in Skyline. You should see a checkbox for "Enable audit logging" in the top right corner of the "Audit Log" window. If you are not seeing the checkbox make the window bigger or click the little triangle icon in the top right corner to see the checkbox. Uncheck this box. You will see a warning dialog with a message like:

"This will clear the audit log and delete it permanently.....Do you want to proceed?".

Click "Yes" and save the document. After this you should be able to upload the document to Panorama. Let us know if you run into any issues.

In your message you say that you tried the upload again "after the notes in Skyline were removed". Does this mean that you have already tried the upload after removing the audit log and it still failed with the same error? To make sure that the audit log is really gone open the folder that contains the Skyline document (.sky file). You can do this in Skyline from the File > Open containing folder menu. Delete the audit log file (.skyl) if it is still there.